Error en la Migracion de host

  • dragonl
  • Autor del tema
  • Invitado
  • Invitado
7 años 11 meses antes - 7 años 11 meses antes #1525 por dragonl
COM_KUNENA_MESSAGE_CREATED_NEW
Hola amigos. Vereis tengo un portal en Joomla y he migrado a otro Host. Hice un backup desde el Cpanel, tanto de la base de datos como del directorio "public_html" que es donde tenia todos los archivos, y configure el archivo "configure.php" correctamente.

Pues bien, lo he pasado al otro host, cambie las DNS... El error radica cuando intento entrar en el administrador de Joomla.

Cuando pongo: "http://hentaiclub.es/administrator/" me redirige automaticamente a: "http://hentaiclub.es/installation/index.php". Y solo aparece una pantalla en blanco con el siguiente texto:

"No configuration file found and no installation code available. Exiting..."

¿Sabeis como puedo solucionarlo? he trasteado pero no se me ocurre nada U_U.
Last edit: 7 años 11 meses antes by dragonl.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
7 años 11 meses antes #1526 por juan
COM_KUNENA_MESSAGE_REPLIED_NEW
¿Has borrado el fichero de instalación? Puede que el error venga de por ahí.

De todos modos ¿tienes disponible tu web en tu antiguo host? Si es así, no te compliques y ahorra problemas usando Akeeba Backup.

Tienes un manual para la migración de tu web con este componente aquí: http://ayudajoomla.com/joomla/tutoriales/284-realizar-copia-de-seguridad-de-joomla-con-akeeba-backup.html y http://ayudajoomla.com/joomla/tutoriales/291-restaurar-copia-de-seguridad-de-joomla-con-akeeba-backup.html

Podríamos matarnos a ver ahora que le pasa a tu web pero te aseguro que con Akeeba todo es fácil, sin problemas y llevo ya unas pocas migraciones hechas.

Un saludo,

Juan A. Chaves - Fundador Ayuda Joomla
ayudajoomla.com - @ayudajoomla
Antes de escribir en el foro revisa sus reglas

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

  • dragonl
  • Autor del tema
  • Invitado
  • Invitado
7 años 11 meses antes #1527 por dragonl
COM_KUNENA_MESSAGE_REPLIED_NEW
Gracias juan. El fichero de instalacion lo borre una vez que hice el portal hace ya unas semanas. Hice mas o menos lo que lei en tutoriales, hacer backup de todo el directorio y base de datos, y luego configurar el archivo ese de configure.php para poner correctamente los datos de la nueva base de datos y demas.

Voy a intentar hacer lo del Akeeba Backup, el problema esta que el dominio ahora apunta al nuevo server y no puedo entrar en el viejo, pero creo que hay una direccion temporal...

Y una cosa, si hago la migracio mediante Akeeba Backup tengo que borrar antes todo lo subido no? y la base de datos...

Muchas gracias juan por la ayuda ^^

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

  • alejandro
  • Invitado
  • Invitado
7 años 11 meses antes #1528 por alejandro
COM_KUNENA_MESSAGE_REPLIED_NEW
uhmm y no será un problema de permisos con el archivo configuration.php??? o con la información de algunas de las variables que este archivo contiene y que han sido modificadas al cambiar de host (rutas del servidor para log y path por ejemplo)

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

  • dragonl
  • Autor del tema
  • Invitado
  • Invitado
7 años 11 meses antes #1540 por dragonl
COM_KUNENA_MESSAGE_REPLIED_NEW
juan he seguido los pasos del tutorial que me has enviado. Hice copia de seguridad del sitio antiguo con el Akeeba Backup, lo descargue al disco duro, lo descomprimi todo, y lo he subido al nuevo servidor.

El siguiente paso, una vez todo subido, se supone que es cargar la pagina web en mi caso www.hentaiclub.es y seguir las indicaciones, pero... me aparece un monton de palabras que no se que significa

"mark( 'afterLoad' ) : null; /** * CREATE THE APPLICATION * * NOTE : */ $mainframe =& JFactory::getApplication('site'); /** * INITIALISE THE APPLICATION * * NOTE : */ // set the language $mainframe->initialise(); JPluginHelper::importPlugin('system'); // trigger the onAfterInitialise events JDEBUG ? $_PROFILER->mark('afterInitialise') : null; $mainframe->triggerEvent('onAfterInitialise'); /** * ROUTE THE APPLICATION * * NOTE : */ $mainframe->route(); // authorization $Itemid = JRequest::getInt( 'Itemid'); $mainframe->authorize($Itemid); // trigger the onAfterRoute events JDEBUG ? $_PROFILER->mark('afterRoute') : null; $mainframe->triggerEvent('onAfterRoute'); /** * DISPATCH THE APPLICATION * * NOTE : */ $option = JRequest::getCmd('option'); $mainframe->dispatch($option); // trigger the onAfterDispatch events JDEBUG ? $_PROFILER->mark('afterDispatch') : null; $mainframe->triggerEvent('onAfterDispatch'); /** * RENDER THE APPLICATION * * NOTE : */ $mainframe->render(); // trigger the onAfterRender events JDEBUG ? $_PROFILER->mark('afterRender') : null; $mainframe->triggerEvent('onAfterRender'); /** * RETURN THE RESPONSE */ echo JResponse::toString($mainframe->getCfg('gzip')); "

¿Alguna idea en que estoy fallando? U_U

Saludos!

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
7 años 11 meses antes - 7 años 11 meses antes #1541 por juan
COM_KUNENA_MESSAGE_REPLIED_NEW
Estos son los pasos que has tenido que seguir:
1 - Borrar todo lo que ya subiste en tu nuevo server.
2 - Crear el respaldo de tu web con Akeeba Backup
3 - Subir el fichero .jpa el kickstart.php y el kickstart.ini de tu idioma (es obvio que el español).
4 - Poner www.hentaiclub.es/kickstart.php y seguir el asistente, tienes que tener a mano los datos de la base de datos porque te los va a pedir.

Hazlo tal y como te digo y me cuentas...

un saludo y suerte,

Juan A. Chaves - Fundador Ayuda Joomla
ayudajoomla.com - @ayudajoomla
Antes de escribir en el foro revisa sus reglas
Last edit: 7 años 11 meses antes by juan.
Los siguientes usuarios han agradecido: dragonl

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Gracias a Foro Kunena