/component/content/frontpage

  • Alberto
  • Autor del tema
  • Invitado
  • Invitado
10 años 4 meses antes #35 por Alberto
COM_KUNENA_MESSAGE_CREATED_NEW
Buenas, e aqui una pregunta un tanto rara, al buscar en google por: /component/content/frontpage salen una gran lista de webs Joomla, y obviamente cando hago una busqueda con el nombre de mi web, sale de segunda esa URL, y no me gusta, porque la web sale como "desmontada" con un par de articulos solo.

Sin embargo, no a todos los Joomla, le pasa, ya que tengo amigos con web Joomla y hago suweb.com/component/content/frontpage y da error de que no se encuentra, como puedo hacer yo para que me salga lo mismo.

Saludos!

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

  • alejandro
  • Invitado
  • Invitado
10 años 4 meses antes #36 por alejandro
COM_KUNENA_MESSAGE_REPLIED_NEW
Eso es porque tienes activadas las urls amigables. A nosotros en el RSS de esta web nos salía el enlace al index como /component/content/frontpage y también se nos descuadraba. El problema del RSS lo solucionamos modificando a mano un archivo del core (cosa no recomendada).

No se me ocurre como corregir eso, pero una idea interesante puede ser hacer un 301 en el htaccess para que te redireccione esa url al index de tu web.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

  • Alberto
  • Autor del tema
  • Invitado
  • Invitado
10 años 4 meses antes #37 por Alberto
COM_KUNENA_MESSAGE_REPLIED_NEW
Muchas gracias por contestar tan rápido, pero como hago esa redirección si en verdad esa carpeta no existe..
Le mandé un correo a mi hosting diciendo que no me iba la redireccion a través de CPANEL,
Por lo que veo no existe la carpeta component dentro de la carpeta web, así que ya tienes que tener alguna redirección en otro sitio para que funcione el acceso a:
www.miweb.com/web/component/content/frontpage

Como lo haría desde el .htaccess

saludos y gracias otra vez

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

  • alejandro
  • Invitado
  • Invitado
10 años 4 meses antes #38 por alejandro
COM_KUNENA_MESSAGE_REPLIED_NEW
pon algo parecido a esto

redirect 301 /url_antigua.html http://www.dominio-nuevo.com/url-nueva/

La redirección cpanel no te funcionará porque esa carpeta no existe realmente, ha sido generada con alguna de las expresiones regulares del htaccess que trae joomla por defecto. No se exactamente que regla hay que tocar porque no lo he investigado personalmente. Tampoco te garantizo que lo que te he dicho funcione... pero se pue hacer esa prueba.

Suerte

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

  • Alberto
  • Autor del tema
  • Invitado
  • Invitado
10 años 4 meses antes #39 por Alberto
COM_KUNENA_MESSAGE_REPLIED_NEW
Funciona perfectamente, muchísimas gracias por tu tiempo y ayuda.


Supongo que este "error" será un problema que con futuras versiones intentaran mejorar, ya que parece que solo pasa con las URLs amigables activadas, de todas formas voy a postear en la web oficial de Joomla para ver que me pueden decir sobre el tema, ya que te vayan a buscar en Google y te salga asi tu web Joomla es un peligro para las visitas que puedas tener, ya que se van a encontrar con una web un tanto rara, porque no entiendo bien en el funcionamiento ese, te muestra algunos artigos al azar...

saludos, Alberto.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
10 años 3 meses antes #106 por vercetiii
COM_KUNENA_MESSAGE_REPLIED_NEW
Hey amigo muchas gracias, estoy montando mi web, y si es por lo que tu dices, es por que tengo activadas las url amigables, mil gracias... ahora si continuo con mi trabajo, gracias.....

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Gracias a Foro Kunena