MUY_RARO::copie sitio y se sincronizan las BD???

  • rafael8a
  • Autor del tema
  • Invitado
  • Invitado
8 años 4 meses antes #1866 por rafael8a
COM_KUNENA_MESSAGE_CREATED_NEW
Me sucede algo muy extraño.

Se trata de un sitio en joomla 1.x q despues mudare a 1.5 o 1.6, pero por ahora solo quiero hacerle unos cambios.

Dejo el sitio original mientras hago las pruebas, y segui las instrucciones para "mudar" a un nuevo dominio.

En realidad lo q estoy haciendo es crear una copia del sitio original en un dominio q tengo sin usar y estoy haciendo alli las pruebas.

Las instrucciones que segui son las que encontre aca::
http://www.joomlaspanish.org/foros/archive/index.php?t-7940.html

y que son::
1 - sube todo por FTP o file manager del server toda la info sin el configuration.php y con la carpeta installation
2 - respalda la BD localhost
3 - realiza una nueva instalación online
4 - elimina las tablas generadas en la BD por la nueva instalación
5 - importa el respaldo SQL que hiciste del localhost

Todo bien, pero se presenta algo:: lo q hago en la BD del sitio de pruebas se refleja en el sitio original, y viceversa. Pero extrañamente no todo:: instale una nueva plantilla en el sitio nuevo, y esta no se instalo en la original, pero cambios en articulos y cambios en seleccion de plantilla x defecto si se reflejan. Al cambiar la plantilla en el sitio de pruebas, pues ubico y coloco la nueva imagen, pero en el sitio original al ver el frontend sale el error q no encontro la plantilla.

Encontre en algun foro q alguien tenia este problema y le contestaron q cambiara nombres de bd, user y pass, pero alli otra cosa, probe hacerlo y haciendo los cambios en configuration.php y demas, y no lo acepta.

Cuando vuelvo a colocar los nombres originales si entra otra vez (la nueva instalacion joomla en el sitio de pruebas lo hice todo igual al sitio original, pero en otro dominio).

Entonces probe borrar configuration.php y correr de nuevo la instalacion y cuando llego a la seccion de BD no me permite colocar otros datos distintos a los del sitio original (y la BD en este punto no tiene el nombre de la BD original, sino q esta renombrada al nombre nuevo q estoy tratando de ponerle en la nueva instalacion).

Encontre en la BD original varias entradas q tenian URLs absolutas del sitio original, pero aun cuando las cambie por sus contrapartes del sitio de pruebas, se sigue dando la situacion de sincronizacion indeseada q describo.

Queria preguntar::
Estos datos q hacen q las carpetas del sitio-copia esten sincronizadas con el sitio-original:: se guardan en la BD?.. en q parte?..

o como le podria hacer para solucionar (q no se sincronicen, q sean instalaciones y BD independientes).

Quizas el joomlapack me solucione, pero quisiera llegar al fondo de esta curiosa situacion, y saber q pasa, porq ya me rompi el coco antes de postear esto a ver si alguien me ilumina.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

  • tonycuartas
  • Invitado
  • Invitado
8 años 4 meses antes #1867 por tonycuartas
COM_KUNENA_MESSAGE_REPLIED_NEW
bueno, pues para esto los pasos que siempre sigo son los siguientes

1 copio todo el contenido de public html
2 quito el archivo configuration php
3 miro que la carpeta instalation este bien escrita
4 copio la base de datos
5 instalo en el nuevo servidor
6 al terminar importo la base de datos antigua

y ya esta.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

  • rafael8a
  • Autor del tema
  • Invitado
  • Invitado
8 años 4 meses antes #1870 por rafael8a
COM_KUNENA_MESSAGE_REPLIED_NEW
Pues creo q eso es exacto lo q hice...

Algo tiene q haber q hace q ambas BD esten SYNC, y me gustaria saber q es.

Eventualmente actualizare, mas me gustaria mucho saber q pasa en este caso.

Tengo los 2 dominios apuntando a los mismos DNS, pero ya q ambos dominios estan cada uno en su propio espacio, con su propio cpanel, su propio phpmyadmin, etc.. no veo por ese lado como se estaria colando esto.

Me gustaria saber si esto es propio de joomla, y como puede esto pasar.. y si es por motivos ya de estructura de hosting, dns o cosas asi, pues me gustaria muchisimo mas conocer las causas.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

  • rafael8a
  • Autor del tema
  • Invitado
  • Invitado
8 años 3 meses antes #1917 por rafael8a
COM_KUNENA_MESSAGE_REPLIED_NEW
- - - - - - - -
AUTORRESPUESTA::
- - - - - - - -
En realidad no se estaban sincronizando las BD, se estaba usando la misma del sitio original.

Lo de la plantilla que se instalo en un sitio si, y en el otro no fue un hibrido misterioso q ya ni quiero pensar q paso alli.

Me costo un mundo encontrar la solucion, pero la halle.
Y como suele sucecer, los problemas mas grandes, tienen
soluciones muy simples::

-Entrar al back-end del sitio copia
-Menu > Sitio > Configuracion Global
-Pestaña > Base de Datos
-Nombre usuario MySQL > nombreDeLaCuentaParaEntrarEnCPanel_userDeBD
-Base de datos MySQL: > nombreDeLaCuentaParaEntrarEnCPanel_nombreDeBD
-Salvar y hacer los cambios en configuration.php

No se nada de servidores, pero deduzco que ya que
en esta misma pestaña en:: "Nombre del servidor:"
se coloca el mismo (localhost en mi caso), pues como que el espacio
para las BD en todas las subCuentas de una misma cuenta se comparte. Digo yo. Es la unica respuesta q encuentro a este entuerto.

Ojala pueda ayudar otra gente q venga a parar en este post, porque
la solucion no me fue facil de hallar.

Saludos.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Gracias a Foro Kunena