Problema al migrar de appserv Windows a LAMP Suse

Más
6 años 10 meses antes - 6 años 10 meses antes #2794 por Guty
COM_KUNENA_MESSAGE_CREATED_NEW
buenas a todos.

veran he seguido el tutorial "Migrar Joomla de un servidor local a un servidor de Internet" al pie de la letra para migrar mi web en joomla a un servidor LAMP Suse.

pues al principio monte mi web joomla en un Winsows XP con appserv, y ahora me pidieron que migre a un servidor Suse de la empresa, pude instalar el servidor LAMP sin mayores complicaciones y exportar e importar la Base de datos de joomla tambien sin ningun problema, tambien deje el archivo configuration.php de la nueva instalacion de joomla (ojo este archivo no se genero automaticamnete en la raiz del directorio, pero me genero los parametros para que yo copiase en un txt y gudarlo con el nombre configuration.php).

la web de la nueva instalacion se mostraba perfectamente, pero cuando copio los archivos de la web que quiero migrar, simplemnte la web no se muestra en lo abosoluto! sin menssaje ni nada al respecto!

nota: la web es solo para uso de la intranet.

por favor necetiso su ayuda!
Last edit: 6 años 10 meses antes by Guty.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

  • alejandro
  • Invitado
  • Invitado
6 años 10 meses antes #2797 por alejandro
COM_KUNENA_MESSAGE_REPLIED_NEW
La página en blanco suele ser sinónimo de algún tipo de error de PHP. Lo más habitual es que los servidores en explotación tengan desactivado el reporte de errores.

Mira a ver si te pueden dar acceso al log de errores de php o si lo pueden activar en los archivos de configuración.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
6 años 10 meses antes #2799 por Guty
COM_KUNENA_MESSAGE_REPLIED_NEW

alejandro escribió: La página en blanco suele ser sinónimo de algún tipo de error de PHP. Lo más habitual es que los servidores en explotación tengan desactivado el reporte de errores.

Mira a ver si te pueden dar acceso al log de errores de php o si lo pueden activar en los archivos de configuración.


hola alejandro gracias por contestar, veras e podido activar los reportes de errores php en mi apache y me muestra el sigueinte error:

Warning: Unknown: failed to open stream: Permission denied in Unknown on line 0 Fatal error: Unknown: Failed opening required '/srv/www/htdocs/joomla/index.php' (include_path='.:/usr/share/php5:/usr/share/php5/PEAR') in Unknown on line 0

alguna idea de que podria ser? ayudame por favor

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

  • alejandro
  • Invitado
  • Invitado
6 años 10 meses antes #2800 por alejandro
COM_KUNENA_MESSAGE_REPLIED_NEW
uhmmm.... pues... no lo tengo muy claro.

Quizás sea un problema de permisos de los archivos => Revisa que las carpetas tienen permisos 755 y los archivos php 644. Sin embargo del mensaje de error también dice algo de Pear => Revisa si tu configuración de php tiene activada esta extensión.

Espero que te sirva!!!

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
6 años 10 meses antes - 6 años 10 meses antes #2803 por Guty
COM_KUNENA_MESSAGE_REPLIED_NEW

alejandro escribió: uhmmm.... pues... no lo tengo muy claro.

Quizás sea un problema de permisos de los archivos => Revisa que las carpetas tienen permisos 755 y los archivos php 644. Sin embargo del mensaje de error también dice algo de Pear => Revisa si tu configuración de php tiene activada esta extensión.

Espero que te sirva!!!


hola alejandro nuevamente gracias por tu respuesta.

veras he podido arreglar mi problema, ese mensaje era por que no tenia los permisos suficientes para acceder al direcotrio de joomla asi que con por consola otorgue permisos(chmod 777 -R /srv/www/htdocs/joomla).

luego me surgio un problema con la exntesion mbstring el cual no estaba instalado en php, eso lo arregle muy facilmente instalando la exntesion con el yast/software magnament, y reiniciando el servicio apache.

y guala!! la pagina fucniona de maravilla, muchas gracias por tus respuestas un saludo cordial!
Last edit: 6 años 10 meses antes by Guty.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Gracias a Foro Kunena