Diferencias en IE y Firefox en plantilla

  • PepeCordoba
  • Autor del tema
  • Invitado
  • Invitado
10 años 1 semana antes #45 por PepeCordoba
COM_KUNENA_MESSAGE_CREATED_NEW
estoy utilizando la plantilla siteground-j15-69, he modificado las imagenes solo en el color, y el codigo css tambien en los colores.

Resulta que segun se vea en firefox o IE, la diferencia es notable, el logo solo sale una parte.

Mira tu mismo

alguna sugerencia, ¿para corregirlo?

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
10 años 1 semana antes #46 por juan
COM_KUNENA_MESSAGE_REPLIED_NEW
A lo largo de todas las webs que realices Pepe, la incompatibilidades con IE van a ser constantes porque Microsoft se salta los estandares web a la torera y sigue sus propios estandares.

Mi recomendaciones son 2: o bien te pones a tocar el css del template para corregir los desajustes que aparecen en IE (si no recuerdo mal se podia hacer algo en css para darle un estilo distinto dependiendo del explorador en el que se iba a mostrar la web) o cambias de template y te aseguras que se vea bien con IE (por desgracia sigue siendo el explorador más común hoy en día).

Si tengo tiempo entre tocho y tocho de apuntes te miro lo que te digo de lo del css por si no lo encuentras.

un saludo

Juan A. Chaves - Fundador Ayuda Joomla
ayudajoomla.com - @ayudajoomla
Antes de escribir en el foro revisa sus reglas

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

  • alejandro
  • Invitado
  • Invitado
10 años 1 semana antes #48 por alejandro
COM_KUNENA_MESSAGE_REPLIED_NEW
También puedes utilizar herramientas como Firebug (para Firefox) y IE Toolbar Developer (para IE)que te permiten navergar por el código html y ver los css que se aplica a las etiquetas.

Muchas de estas cosas las saco por ensayo y error, para esto Firebug es muy bueno, te permite editar el css y te muestra los cambios al momento, si ves que son los adecuados solo tienes que irte a tu hoja de estilos y editarla con las modificaciones que has realizado.

No estoy seguro... pero prueba a meterle el atributo height al div con id=logo, a lo mejor el problema es porque ese atributo se ha omitido. Muchas veces el IE6 ,que es el yo tengo instalado porque es el que mas problemas me suele generar, si no esta el atributo definido da problemas. Sin embargo con firefox no ocurre eso.

Un saludo.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
10 años 1 semana antes - 10 años 1 semana antes #49 por juan
COM_KUNENA_MESSAGE_REPLIED_NEW
Si vas a corregir el template para hacerlo compatible con IE te recomiendo lo siguiente:
    1. Dejar una copia de la hoja de estilos sin retocar (esta te servira para los navegadores Firefox, Chrome, etc) y cargarla mediante la siguiente instruccion en el index.php
<!--[if !IE]><!-->
<link rel="stylesheet" type="text/css" href="tu-url-css.css" />
<!--<![endif]-->
Este trozo de codigo es ignorado por todas las versiones de IE existentes y asi podras cargar el CSS para el resto de navegadores[/ul]
    2. Crear un CSS a partir del original con los cambios que tengas que realizarle para que se muestre correctamente en IE

La importancia de tener dos CSS separados es que los cambios que realices en IE no afecten a la visualización de la página en el resto de navegadores. Espero que esto te sea de ayuda, ya nos comentaras como te ha ido el tema.

un saludo,

Juan A. Chaves - Fundador Ayuda Joomla
ayudajoomla.com - @ayudajoomla
Antes de escribir en el foro revisa sus reglas
Last edit: 10 años 1 semana antes by juan.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

  • PepeCordoba
  • Autor del tema
  • Invitado
  • Invitado
10 años 1 semana antes #51 por PepeCordoba
COM_KUNENA_MESSAGE_REPLIED_NEW
Buscando en el codigo, he observado lo siguiente:

Código:
#logo{
float:left;
width:728px;
line-height:24px;
padding:31px 0 0 0;
margin:0 auto;
text-align:left;
}

#logo a, #logo a:link, #logo a:hover{
font-size:48px;
font-family:Tahoma;
font-weight:bold;
text-align:left;
text-decoration:none;
letter-spacing:1px;
color:#003399;/***letra logo***/
padding:0 0 0 20px;
margin:0;


Yo habia aumentado font-size:48px; a 48, sin embargo mas arriba en el codigo observo lo siguiente; line-height:24px; he cambiado el 24 por el 48 y lo he probado en localhost y va bien.

Siento haberos hecho perder el tiempo, pero si no es por vuestra ayuda no se me hubiera ocurrido buscar en el css para modificar esto.

Llevo un tiempo con esto, antes con IE7 no observaba nada diferente, ahora con el 8 se cortaba el texto del logo.

Tambien si os habeis fijado el pluging Xtypo no sale bien. pero esto es una cosa menor

Nuevamente gracias

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

  • alejandro
  • Invitado
  • Invitado
10 años 1 semana antes #52 por alejandro
COM_KUNENA_MESSAGE_REPLIED_NEW
line-height se utiliza para el interlineado de los textos, pero si haciendole el cambio te sale bien la web pues OLEEE el truquito !!!

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Gracias a Foro Kunena