Error Joomlapack 2.1.1

  • siaph
  • Autor del tema
  • Invitado
  • Invitado
9 años 11 meses antes #4 por siaph
COM_KUNENA_MESSAGE_CREATED_NEW
Hola,

Lo primero de todo, enhorabuena por la Web, porque tiene muy buena pinta, con manuales sencillos, que seguro a la gente, como yo, que se inicia en estas cosas les vendrá muy bien. La verdad que la encontré ayer por la noche, buscando solución al problema que a continuación expondré, y es que me sorprendió tanto, que decidí que fuese este el primer foro en postear mi tema, a pesar que ya soy asiduo a otros foros...

Explicando ya mi problema, actualmente tengo una web PHP Nuke, a la que quiero jubilar por Joomla, y actualmente estoy probando Joomla 1.5.10 en Localhost, con Appserv 1.5.9 en mí ordenador, el problema que veo es que tiene pocas cosas instaladas, y he visto, que con Joomlapack 2.1.1, puedo hacer una copia de seguridad de la BD y de todos los archivos, así que deduzco que sí monto mi Web en Local, podré instalarla en el server tal y como la tengo en Local.

Estoy intentando instalar esta web, con la copia de seguridad de Joomlapack 2.1.1 en un server gratuito para ir probando, y me indica el siguiente problema:
Can't open file (/home/www/miweb.100webspace.net/installation/includes/../sql/joomla.sql) for import

Please, check that your dump file exists and it is readable by the web server.

He mirado en otros foros, concretamente en uno en inglés, y comentan que hay que añadir el archivo "joomla.sql" en el directorio "/miweb.100webspace.net/installation/sql/joomla.sql", ya que el directorio que me indica el error ("/home/www/miweb.100webspace.net/installation/includes/../sql/joomla.sql") no existe, así que intento subir vía FTP (Filezilla) ese archivo a la carpeta comentada ("/miweb.100webspace.net/installation/sql/joomla.sql"), y es curioso, aparece el archivo y de pronto desaparece en el cliente FTP.

Entonces, es este el problema al que estoy buscando solución.

Saludos.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

  • alejandro
  • Invitado
  • Invitado
9 años 11 meses antes - 9 años 11 meses antes #5 por alejandro
COM_KUNENA_MESSAGE_REPLIED_NEW
No se porque no te aparecerá el archivo sql, a lo mejor es por alguna restricción del hosting gratuito que utilizas :S. Siempre puedes realizar una instalación de Joomla manual que son pocos pasos.

1º Coges todo el contenido de tu sitio web y lo subes al servidor

2º Supongo que tendrás phpmyadmin o algo similar para tocar la base de datos en el hosting, tienes que restaurar tu base de datos en el servidor

3º Edita las siguientes líneas del archivo configuration.php para que Joomla apunte a la nueva base de datos.

var $host = 'direccion_del_host';
var $user = 'usuario_de_la_bd';
var $password = 'contraseña';
var $db = 'nombre_de_la_bd';

De la instalación manual de joomla me gustaría hacer un artículo para la web, lo tengo en la carpeta de pendientes :blush:

Espero que te pueda servir de ayuda, y muchas gracias por estrenarnos el foro :)
Last edit: 9 años 11 meses antes by alejandro.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

  • siaph
  • Autor del tema
  • Invitado
  • Invitado
9 años 11 meses antes #6 por siaph
COM_KUNENA_MESSAGE_REPLIED_NEW
Lo he intentado manualmente, configurando el archivo "congiguration.php" y subiendo el archivo "joomla.sql" en la pestaá SQL de phpMyadmin, con el siguiente error,
jtablesession::Store Failed
DB function failed with error number 1146
Table 'pabpre0_joomla.tzsen1_session' doesn't exist SQL=INSERT INTO `tzsen1_session` ( `session_id`,`time`,`username`,`gid`,`guest`,`client_id` ) VALUES ( '83f418ljkae6vja5jglofjsgu4','1241175958','','0','1','0' )

En principio en el server gratuito tengo las 115 tablas de la BD, que tengo en Local, pero me salta con ese error....

Yo una cosa que no tengo clara, es que con Joomlapack puedes tener 2 tipos de archivos: ZIP y JPA. El primero conocido, pero que ya te indica el programa que podrás tener algún error, el segundo lo desconozco, pero no te indica nada, pero como no sé como se maneja ese archivo no lo he usado...no sé si el problema está ahí, ya que he leido que al descomprimir ZIP puede dar algún error.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

  • alejandro
  • Invitado
  • Invitado
9 años 11 meses antes #7 por alejandro
COM_KUNENA_MESSAGE_REPLIED_NEW
El error te dice que no existe la tabla 'pabpre0_joomla.tzsen1_session', a lo mejor el archivo sql que utilizas le faltan líneas. Prueba a hacerle un dump desde la consola con algo parecido a esto
mysqldump --opt -u nombre_usuario -p base_datos > copia_seguridad.sql
así conseguirás un archivo con todas las sentencias sql para generar la base datos, es decir con los create, insert, etc.

Con respecto al formato JPA o ZIP, yo siempre he usado el formato zip y no me ha dado ningún problema, desconozco el funcionamiento del JPA porque no lo he usado nunca:blush:

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

  • siaph
  • Autor del tema
  • Invitado
  • Invitado
9 años 11 meses antes - 9 años 11 meses antes #8 por siaph
COM_KUNENA_MESSAGE_REPLIED_NEW
Lo he hecho con el archivo Joomla.sql que me genera Joomlapack, así que no debería haber problemas. Una cosa curiosa, es que cuando ejecuto la BD, o sea, este archivo que te comento, este .sql pesa como 600 KB, y pone que el límite es de 8 KB, sin embargo si pego el contenido, no me da ningún error. Comento esto, ya que no soy experto en esto, y es probable que algo esté haciendo algo mal...es más, me comentas hacer un "dump" desde la "consola". Te refieres a que pege este contenido:
mysqldump --opt -u nombre_usuario -p base_datos > copia_seguridad.sql

sustituyendo el nombre de usuario y el de la BD que tengo, y lo ejecute en phpMyadmin???? No valdría exportar la BD que tengo en Local??? Perdona mi ignorancia, en un año con Nuke he aprendido varias cosas, pero aún me faltan otras tantas.

Saludos.

EDITO:Edito el mensaje, para no llenaros de mensajes inútiles vuestro foro. Finalmente he borrado la BD y he exportado la que tengo en Local e importado en el server gratuito, y más o menos ha funcionado, con la sorpresa que el phpMyadmin que tengo en local es 2.5.9 y el del server debe ser un 2.6.x,pero ha colado.

Digo que más o menos ha funcionado, porque por ejemplo, ninguna de las 2 galerías de imágenes funcionan correctamente (Morfeoshow y RS Galley). También tengo problemas para visionar correctamente las imágenes de los artículos. Tampoco me funciona el contador (el que explicáis en un tutorial en esta web). Otra cosa que tampoco me funciona, son los enlaces a los mensajes del foro phpBB3, lo cual es normal, porque al instalar el módulo de últimos mensajes, te pregunta la ruta, y supongo que estará la de Local, que obviamente es distinta a la del server.

Bueno, esto es lo que hay, si quieres ver la web este es el enlace,

http://viella.100webspace.net/

Saludos.
Last edit: 9 años 11 meses antes by siaph.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Gracias a Foro Kunena